Ir para conteúdo

elppans

Grand Chase History Linux - 2ª Versão

Posts Recomendados

AirON    872

Muito bacana seu tuto, as vezes me da vontade de instalar linux mas ai eu lembro que eu jogo 12312312 jogos que não tem suporte haha 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
elppans    70
5 horas atrás, HanZo disse:

Muito bacana seu tuto, as vezes me da vontade de instalar linux mas ai eu lembro que eu jogo 12312312 jogos que não tem suporte haha 

 

Pra eu me organizar aqui eu só jogo se for Multi plataforma. Então pra mim tanto faz o jogo , que eu consigo jogar em qualquer sistema :gc13:

Compartilhar este post


Link para o post
Compartilhar em outros sites
elppans    70
4 minutos atrás, Dye disse:

Podia fazer um pra Mac e.e

Infelizmente eu não tenho MAC instalado, e não possuo as ferramentas o suficientes para compilar o programa pra MAC. Mas existe um tutorial aqui no fórum que ensina a configurar o GCH no MAC.

Porém é um esquema em que se usa Máquina Virtual, então fica meio lento a jogabilidade.

Então dependemos de que apareça alguém com conhecimentos que queira fazer o mesmo para MAC

Editado por elppans
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
IsaacMarks    93

Maneiro seu tutorial, mesmo eu não tendo Linux isso ajuda bastante pessoas que não tem Windows.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
elppans    70

 
MANJARO x86_64 17.1.2 Hakoila Linux 4.14.14-1, conflito de biblioteca:

 

Som ALSA não funciona e faz o GCH sair. Em modo DEBUG ocorre a seguinte mensagem:

ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so

Porém a biblioteca referida existe, e este é o problema, pois há conflito entre o aplicativo e a biblioteca libasound_module_pcm_pulse.so

Esta biblioteca pertence ao pacote "lib32-alsa-plugins", porém o mesmo é exigido pelos pacotes  manjaro-alsa, steam-manjaro e steam-native. Então só é possível removê-lo se não usar nenhum destes pacotes.

O Manjaro usa o ALSA mesmo sem o pacote "manjaro-alsa", pois ele é apenas um meta-pacote.
Mas para quem possui o Steam, a própria máquina virtual dele já possui a biblioteca, então poderá deixar a mesma renomeada para não ser usado pelo sistema sem problemas:

 

sudo mv /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so.bkp

 

Se qualquer outra distro tiver esta biblioteca em sua versão 32 bits instalado, faça o mesmo teste renomeando a biblioteca.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
elppans    70

 

[ NOTÍCIA ] Nova versão do gcHistory AppImage (2.6_20181402)

Salve pessoal, estou de volta e vou postar a notícia como comentário aqui no post mesmo, dá menos trabalho e não é necessário esperar alguém aprovar o post ;)
Finalmente estou lançando uma nova versão do gcHistory com algumas novidades.

O que mudou com esta versão:

Retirado suporte aos módulos OSS, Xinerama, XRandr, XRender, XShape, UDEV, GLU, GTK3.
Suporte parcial a Wine 64 bits, porém sem o Freetype, devido a erros ao compilar usando 64 bits. Porém, ainda não é possível executar aplicações 64 bits com esta aplicação.
Ativado suporte ao módulo Pulseaudio e configurado a máquina virtual para usar por padrão este módulo ao invés do ALSA que também está ativado.

A aplicação foi compilada usando desta vez o GLIBC Versão 2.26, porém modificada para funcionar em distros com GLIBC Versão 2.23 para cima.
Distros que possuem versão do GLIBC 2.22 pra baixo não terão suporte ao AppImage.

Distros testadas e suportadas:

Manjaro 17.1.4 = GLIBC 2.26
Fedora 27-1.6 = GLIBC 2.26
Mint 18.2 = GLIBC 2.23

Distros testadas e NÃO suportadas:

Mageia 6* = GLIBC 2.22
OpenSuse Leap** 42.3 = GLIBC 2.22

* O Mageia 7 está em desenvolvimento e então talvez nesta versão haverá suporte ao gcHistory. Infelizmente não achei a ISO para Download da versão em desenvolvimento.
** Versão testada do OpenSuse de lançamento regular, ou seja, com foco em estabilidade.
Pelo que pesquisei (mas ainda não testei), o OpenSUSE Leap 15.0 (Versão de TESTE) usa GLIBC 2.26 e o OpenSUSE Tumbleweed (versão Rolling Release) usa GLIBC 2.27.
Portanto estas 2 versões do OpenSUSE tem suporte SIM à nova versão do gcHistory

"Mas como saber qual a versão do meu GLIBC?"
Basta copiar este comando e colar no Terminal (e apertar ENTER):

getconf GNU_LIBC_VERSION

 

Eu renomeei o aplicativo, antes era "gcHistory_VERSÂO_AppImage", agora é "gcHistory.AppImage".
"Ah mas e agora, como faço pra saber qual a versão?" - Simples, via Terminal na pasta onde está o aplicativo, apenas faça o comando:

./gcHistory.AppImage --version


Vai aparecer a versão do Wine usado e o dia em que foi empacotado. A versão do apicativo é a junção das 2 informações.

Quem já usa a versão anterior e tem problemas com o ALSA, antes de iniciar o jogo com o novo aplicativo faça o comando para remover a máquina virtual anterior, senão irá continuar usando o ALSA por padrão:

./gcHistory.AppImage -rvm

 

Após isto use normalmente, irá ser criado uma nova Máquina Virtual usando o Pulseaudio por padrão.
Nesta versão não consegui esconder 100% do DEBUG que aparece ao ser executado. Então ao executar e aparecer um monte de linhas, é normal.

Por favor, ao ocorrer qualquer erro reporte para mim, faça um post no grupo de suporte e se possível, execute usando a opção "-d" (sem aspas) para aparecer o DEBUG completo e cole o resultado neste site: https://pastebin.com/
Adicione o endereço do resultado no pastebin no post do grupo de suporte.


Link para o Download do gcHistory.AppImage:

http://www.mediafire.com/file/gb00qokmr1eag32/gcHistory.AppImage

Link do MD5 para quem quiser verificar:

http://www.mediafire.com/file/35xq1wq027pi7n3/gcHistory.AppImage.md5

 

Até a próxima pessoal... :gc2:

5aa4559bb0154_Capturadetela_2018-03-10_18-59-50.jpg.2ea3291eda7e78825ad4d2d8b77613c7.jpg

Editado por elppans
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
elppans    70

[ Notícia ] Pacote Grand Chase History + gchLinux APP

 

Pessoal, finalmente o pacote completo.

Neste pacote do jogo, usei o patch manual de atualização da Staff de 06.03.2018 e fiz uma atualização via Launcher de 18.03.2018.

Está com o "gcHistory.AppImage" reempacotado em 14.03.2018 com uma correção da criação automática do atalho. Ambos tem seu md5sum para verificar os pacotes.

 

Clique aqui para baixar o Grand Chase History Linux

Se quiser verificar com o md5sum, clique aqui para baixar

 

Para quem quiser baixar apenas o aplicativo, não o jogo completo, basta ir à minha notícia anterior, pois foi atualizado os links para a versão nova com a correção.

 

5ab2eefab1e75_Capturadetela_2018-03-18_16-33-51.png.4999fccea3f3d94189dc674d9cb3fef6.png

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
elppans    70

[ NOTÍCIA ] FIM

Pessoal, No grupo do face já fiz uma postagem e irei notificar aqui também, algo que não pode ser do agrado de alguns.
Devido ao tempo e outras prioridades, acabei deixando de lado o desenvolvimento do gcHistory.AppImage.
Também não sei quantas pessoas estão usando e se o App está funcionando adequadamente a quem está usando. Pois ninguém reporta o uso do mesmo. 
Então até sábado irei fechar o grupo de suporte no facebbok e também o desenvolvimento por definitivo.

Porém, por hora não vou remover os arquivos do mediafire, mas não haverá mais atualizações.

Com isto, meu aplicativo entra em modo Legacy e deve funcionar normalmente por muito tempo, tendo em vista que mesmo com o avanço do programa original Wine, até o presente momento não há outra forma de usar o jogo no Linux sem o AppImage que criei.

Compartilhar este post


Link para o post
Compartilhar em outros sites
elppans    70

[NOTÍCIA] Erro de módulo

 

Pessoal, após a última ATT, começou a ocorrer um erro ao carregar módulo:

1976692021_Capturadetela_2018-08-18_02-08-22.png.95e963b154125ec991b94925381183e3.png

De acordo com o suporte no Discord, perguntei para algumas pessoas sobre o erro ví que o mesmo erro é ocorrido no Windows 10 de algumas pessoas por alguma razão:

modulo_core.dll_win10.png.8599b36aa3bcb0ceec6ee50191c4e0f5.png

 

Após um reinicio do servidor as 4 da manhã percebi a diferença no nome do arquivo, que voltou para grandchase.dll, se não estou enganado, pelo menos é o que eu percebi de diferente na pasta. Porém o erro continua.

Então decidi ainda não fechar o grupo enquanto o erro persistir ou pelo menos fazer mais testes para ter certeza se dá pra contornar ou não.
Se o resultado for negativo, infelizmente vai ser realmente o fim do APP, com o grupo aberto ou não. Pelo menos neste server, pois pelo que me disseram a um tempo atrás, em testes feitos parece que funcionou em outros locais... Não sei, pois só jogava aqui no GCH desde o começo, não é a toa que coloquei o nome do meu app de "gchLinux"

Bem... Queria que mesmo fechando o grupo no face, o app continuasse funcionando neste server, mas agora não sei se vai dar ☹️

Compartilhar este post


Link para o post
Compartilhar em outros sites
elppans    70

[ Notícia ] Wine + GCH

Pessoal, estive testando o jogo com o Wine mais recente, o 3.14 e o mesmo abriu normalmente só que com uma dll fornecida pelo programador para eu poder testar. porém como a versão 3.14 não tem suporte a IVB nativo, os chars não funcionam corretametne. 
O meu Wine (2.6/19) não está funcionando com esta última atualização, mesmo com a dll de testes fornecida. 
A única saída seria fazer um lançamento do APP com uma nova versão do Wine só que com o path que eu e Pablo Ramon usamos. Mas o mesmo pode demorar um BOM TEMPO para ser crackeado novamente para a nova versão.

Bem... Vamos à luta novamente... Qualquer novidade posto aqui e no grupo do face

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...